adding test in plone

if bin/test not working in your zinstance

in buildout add this, dont forget to add “test” in parts also where you have added the instance etc

[test]
recipe = zc.recipe.testrunner
defaults = [‘–auto-color’, ‘–auto-progress’]
eggs =
${instance:eggs}
Products.XXXX [test]
z3c.form [test]
collective.testcaselayer

Then in Products.XXXX setup.py add this

extras_require = {
‘test’: [
‘plone.app.testing’,
‘selenium’,
],

then run bin/buildout

you should now have the bin/test script in your bin folder

 

 

Advertisements
About

Work is fun!

Posted in Uncategorized

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Disclaimer
All content provided on this "tareqalam.com" blog is for informational purposes only. The owner of this blog makes no representations as to the accuracy or completeness of any information on this site or found by following any link on this site. The owner of [tareqalam.wordpress.com] will not be liable for any errors or omissions in this information nor for the availability of this information. The owner will not be liable for any losses, injuries, or damages from the display or use of this information.
June 2014
M T W T F S S
« May   Sep »
 1
2345678
9101112131415
16171819202122
23242526272829
30  

Enter your email address to follow this blog and receive notifications of new posts by email.

Join 23 other followers

%d bloggers like this: